WordPress Upgrade Error Solved – Fatal error: Cannot redeclare pclziputilpathreduction()



Fatal error: Cannot redeclare pclziputilpathreduction() image

If you've tried upgrading a recent version of WordPress and received this error…

Fatal error: Cannot redeclare pclziputilpathreduction()

…here's what you do.

In a nutshell, deactivate the plugin “WordPress Automatic Upgrade”, then try again and WordPress should upgrade without a hitch.

Here's the explanatory video I posted on YouTube about this error, and how to fix it.

Setup Unmanaged VPS (4 Noobs!) ... with vpsBible
Secure WordPress. Properly. ... with wpCop, the platform's dedicated security website
Olly 'the_guv' Connelly's vpsBible.com site and 'WordPress 3 Ultimate Security' book.


Video: Cannot redeclare pclziputilpathreduction()

Watch the video for a better idea of how to do this.

Guv's on YouTube at http://youtube.com/guvnrDOTcom.

About Fatal error: Cannot redeclare pclziputilpathreduction()

The reason you get this is because your activated plugin, WordPress Automatic Upgrade, is creating problems with WordPress' new in-built automatic upgrade function. But because of this new WordPress feature, you don't need this plugin anymore, anyway. It was a great, highly useful plugin. But it is now negated, so lose it. And then, no more error. Upgrade away.

Did this fix work? Or not? Hmmn! Lemme know below…

5


About the Author:

Olly Connelly (yeah, that's me) blogs at guvnr.com, polices WordPress security at wpCop.com and helps noobs build web servers at vpsBible.com, so if you've got sleeping problems you know where to come.

Discussion

  1. the_guv  June 27, 2009

    good to hear, azzam..tx.

  2. azzam sheikh  June 27, 2009

    Solid information that got me fixed up appreciate it.
    thanks

  3. the_guv  February 16, 2009

    cheers A FAN. appreciate that!

  4. a fan  February 16, 2009

    as always, a great blog entry to solve daily pc problems. Kepp up with the good work!

Add a Comment